Tato verze microsoft.aspnetcore.all je kompatibilní pouze s netcoreapp2.1

Problémy s chybou Visual Studio týkající se výchozí sady rozhraní API pro vytváření aplikace ASP.NET Core jsou vzácné. Stále se však čas od času dějí.

Nejběžnější chyba je: Tato verze Microsoft.AspNetCore.All je kompatibilní pouze s cílovým rámcem netcoreapp2.1.

I když to vypadá složitě, je to poměrně jednoduché vyřešit s ohledem na vývojáře standardy. Níže uvádíme několik kroků.

Jak opravit problém s kompatibilitou s aspnetcore.all

Zdá se, že problém se týká spravedlivého počtu uživatelů. Není to však těžké vyřešit. První návrh se s tím bude pravděpodobně zabývat, ale můžete vždy vyzkoušet další.

Nejjednodušším řešením je pouze aktualizace aplikace Visual Studio. Problém je samozřejmě s verzí netcoreapp, jak to naznačuje chyba. Musíte pouze aktualizovat firmware Visual Studio, odstranit složky bin a obj a znovu je vytvořit.

To by neměl být těžký úkol následovat. Ačkoli mohou existovat některé problémy s kompatibilitou .NET, jsou vzácné.

Po aktualizaci by měl být problém pryč. Na druhou stranu, pokud to nefunguje, zkuste nahradit hodnotu rámce Target správným cílovým prostředím. Úpravou souboru profilu publikování (.pubxml).

Můžete to také provést otevřením projektu, volbou Publikovat> Konfigurovat. Hodnota bude nastavena sama a vše, co musíte udělat, je uložit změny.

Pokud vás stále trápí stejná chyba, zkuste znovu vytvořit profil Publikovat. To by mělo být.

V případě, že se s touto chybou stále potýkáte, zvažte odeslání vašeho problému do fóra Stackoverflow, kde vám dobrý a znalý člověk rád pomůže s řešením problému.

Vzhledem k tomu, že se jedná o obecná řešení, může to vyžadovat specifický přístup pro váš jedinečný problém.

Nezapomeňte se podělit o své myšlenky v sekci komentáře níže. Těšíme se na setkání s Vámi.

Doporučená

4 nejlepší software dělat kvízy v roce 2019
2019
Jak opravit chybu neošetřené výjimky v systému Windows 10
2019
Jak opravit dvojité vrstvené dlaždice hranice v úložišti Windows
2019